Codex

運行 PmWiki 的系統需求:

  1. PHP 4.3 以後的版本
    • 建議使用PHP 5 以後的版本
  2. 可以運行 PHP 環境的 webserver

PmWiki 目前已知可以在下列的 OS/webserver 組合的環境下運行:

  • Apache 1.3 或 2.0, 配合任何作業系統 (Unix, Linux, Windows, and Mac OS/X)
  • Microsoft Internet Information Server , 配合Windows作業系統
  • Linux + LiteSpeedWeb Server 標準版
  • appWeb (一個輕巧,內建PHP的 webserver) 配合Linksys NSLU2 Network Storage Link device

PmWiki 目前已知無法在下列的環境下運行:

  • Mac OS X 以前Mac OS:因為它無法支援 PHP
  • 某些PHP 5.3 的RC版無法和windows配合使用,因為存在一些密碼上的問題。

請參見Standalone recipe ,它提供了特別的解決方案,可以讓您在不需webserver的情況下,仍然可以運行PmWiki。 PmWiki 也可以運行於 行動儲存裝置上。